CoolPipe for SketchUP Interface

Главная | Мой профиль | Выход | RSS
Вы вошли как Гость | Группа "Гости"

[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]

Страница 2 из 7«123467»
Форум » Обсуждения CoolPipe » CoolPipe v1.2 » Баги версии 1.2
Баги версии 1.2
Идущий_по_путиДата: Вторник, 13.03.2012, 21:06 | Сообщение # 16
Группа: Проверенные
Сообщений: 16
Статус: Оффлайн
Quote (Proleg)
У меня при загрузке выдает ошибку

А нужная библиотека из архива iconv.dll лежит в каталоге C:\windows\system32 ???
 
NemesisДата: Вторник, 13.03.2012, 21:42 | Сообщение # 17
Группа: Проверенные
Сообщений: 35
Статус: Оффлайн
Quote (Proleg)
У меня при загрузке выдает ошибку

Не скопировали файл в папку систем 32, как написано в описании установки.
 
ProlegДата: Вторник, 13.03.2012, 21:54 | Сообщение # 18
Группа: Пользователи
Сообщений: 7
Статус: Оффлайн
В том-то и дело, что скопировал. Причем такая-же ерунда и на работе. На обоих компах W7 64х. Версия 1.1 ставится и работает нормально

Сообщение отредактировал Proleg - Вторник, 13.03.2012, 21:58
 
borisovsfamДата: Среда, 14.03.2012, 08:48 | Сообщение # 19
Группа: Администраторы
Сообщений: 136
Статус: Оффлайн
на W64х плагин не тестировался, возможно что iconv и не будет там работать, так что увы....

если бы не кодировки - то таких проблем не было, к сожалению webdialog время от времени возвращает данные в кодировке W1251 - что не допустимо для корректной работы плагина. iconv как раз используется для преобразования кодировки в UTF
 
qazДата: Среда, 14.03.2012, 20:06 | Сообщение # 20
Группа: Пользователи
Сообщений: 4
Статус: Оффлайн
При открытии спецификации программа зависает, когда во 2-м слое более 10 метров труб. При этом, в 1-м слое 52 метра труб.
 
borisovsfamДата: Среда, 14.03.2012, 20:17 | Сообщение # 21
Группа: Администраторы
Сообщений: 136
Статус: Оффлайн
у меня строится спецификация из 25000 отрезков труб разных диаметров и длин, ищите проблему у себя, или пишите лог.... голословные заявления не принимаю
 
qazДата: Среда, 14.03.2012, 21:31 | Сообщение # 22
Группа: Пользователи
Сообщений: 4
Статус: Оффлайн
Quote (borisovsfam)
голословные заявления не принимаю

Ваше право.
 
NemesisДата: Среда, 14.03.2012, 21:55 | Сообщение # 23
Группа: Проверенные
Сообщений: 35
Статус: Оффлайн
qaz, а воспроизвести можете ошибку? чтобы ещё кто-то попробовал.
 
ProlegДата: Среда, 14.03.2012, 22:26 | Сообщение # 24
Группа: Пользователи
Сообщений: 7
Статус: Оффлайн
Quote (borisovsfam)
на W64х плагин не тестировался, возможно что iconv и не будет там работать, так что увы....


а у Вас случайно в планах нет наладить работу на 64х?
 
borisovsfamДата: Четверг, 15.03.2012, 08:23 | Сообщение # 25
Группа: Администраторы
Сообщений: 136
Статус: Оффлайн
Quote (Proleg)
а у Вас случайно в планах нет наладить работу на 64х?


попробуйте следующее:
1. в файле coolpipe_Start.rb удалить строку:

Sketchup::require 'CoolPipe/iconv.so'

2. в файле Service_proc.rb удалить строки везде где встретятся:

encoding = 'WINDOWS-1251'
ic = Iconv.new('UTF-8//TRANSLIT',encoding)
params = ic.iconv(params)


и отпишитесь что из этого вышло, если в диалогах будут кракозябры - то надо будет думать еще как решить этот вопрос
 
qazДата: Четверг, 15.03.2012, 18:03 | Сообщение # 26
Группа: Пользователи
Сообщений: 4
Статус: Оффлайн
Nemesis, ошибка появлялась при использовании трубы с параметрами (Ду 8 мм, Дн 10 мм, Стенка 1 мм, Масса 1 кг/м). Никаких отводов, только трубы (моделировал проводку).
Win XP SP2, SketchUp Pro 8.0.3117.
 
borisovsfamДата: Пятница, 16.03.2012, 09:01 | Сообщение # 27
Группа: Администраторы
Сообщений: 136
Статус: Оффлайн
Не знаю что вы делаете, но у меня по прежнему все нормально работает

Прикрепления: 6239193.jpg(133Kb)
 
NemesisДата: Пятница, 16.03.2012, 10:07 | Сообщение # 28
Группа: Проверенные
Сообщений: 35
Статус: Оффлайн
Я тоже пробовал, не получилось воспроизвести, может конфликт с плагинами? Или название слоев вы дали своё?
 
MWWДата: Пятница, 16.03.2012, 10:30 | Сообщение # 29
Группа: Проверенные
Сообщений: 24
Статус: Оффлайн
Операционная система: Windows 7
Не пойму, почему у меня проблемы со спецификацией?
Старый SketchUp удален, реестр вычищен, Documents and Settings проверен, лишнее удалено.
SU установлен заново.
Может быть какой-то dll-файл в System32 остался?


Прикрепления: 4648659.jpg(100Kb) · 7145390.jpg(120Kb)
 
borisovsfamДата: Пятница, 16.03.2012, 10:42 | Сообщение # 30
Группа: Администраторы
Сообщений: 136
Статус: Оффлайн
плагин полностью автономный, используется только один iconv.dll который должен быть в папке System32

http://ru.wikipedia.org/wiki/Iconv
http://gnuwin32.sourceforge.net/packages/libiconv.htm

поэтому только 32-х разрядные системы (пока)

а по вашим скринам вроде спецификация составляется
 
Форум » Обсуждения CoolPipe » CoolPipe v1.2 » Баги версии 1.2
Страница 2 из 7«123467»
Поиск:


Яндекс.Метрика